Commit d8322109 authored by Andy Brüchert's avatar Andy Brüchert
Browse files

Switched to namespaces and psr-4

parent 399d7e09
......@@ -9,5 +9,10 @@
},
"require-dev": {
"simplesamlphp/simplesamlphp": "~1.13"
},
"autoload": {
"psr-4": {
"SimpleSAML\\modules\\pica\\": "lib/"
}
}
}
<?php
namespace SimpleSAML\Module\Auth\Source;
/**
* This file is part of SimpleSAMLphp Module Pica.
*
......@@ -17,7 +19,8 @@
* along with SimpleSAMLphp Module Pica. If not, see <http://www.gnu.org/licenses/>.
*
* @author David Maus <maus@hab.de>
* @copyright (c) 2015 by Herzog August Bibliothek Wolfenbüttel
* @author Andy Brüchert <bruechert@hab.de>
* @copyright (c) 2015-2021 by Herzog August Bibliothek Wolfenbüttel
* @license http://www.gnu.org/licenses/gpl.txt GNU General Public License v3 or higher
*/
......@@ -27,10 +30,11 @@ use HAB\Pica\Auth;
* Authentication source for Pica-based library systems.
*
* @author David Maus <maus@hab.de>
* @copyright (c) 2015 by Herzog August Bibliothek Wolfenbüttel
* @author Andy Brüchert <bruechert@hab.de>
* @copyright (c) 2015-2021 by Herzog August Bibliothek Wolfenbüttel
* @license http://www.gnu.org/licenses/gpl.txt GNU General Public License v3 or higher
*/
class sspmod_pica_Auth_Source_Pica extends sspmod_core_Auth_UserPassBase
class Pica extends \SimpleSAML\Module\core\Auth\UserPassBase
{
/**
* Error message settings.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment